TIENDA RECOMENDADA Inicio Últimos Temas Consulta con Asesor PCs Destacados Chollos 2ª Mano PC Gamer PC Edición PC Barato/Apu PC Para Todo Comprar Windows / Office Unete a Patreon

Error Q-code 22 en Asus Rog + RAM Corsair

pindio

Miembro del Foro
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Buenos días:

Hace unos años monté una máquina gracias a la ayuda de este foro (ver configuración completa).

Por requerimientos de procesamiento de imágenes para la producción de ortofotografías aéreas, he aumentado de 32GB (16x2) de RAM a 64GB (16x4), todos de la misma marca y modelo Corsair VENGEANCE RGB PRO 16GB, DDR4 3200MHz C16.

Desde que he hecho ese cambio, el PC no inicia. Tengo que apretar el botón reset de reinicio para que se inicie correctamente y cargue W11. Una vez hecho esto, el PC funciona sin problemas con sus 64GB de RAM. La placa (ROG Strix X570-E Gaming) me indica que el error Q-code es el 22, que corresponde con un problema de la RAM (Q-LED detenido en amarrillo).

He probado a instalar sólo los dos módulos recién comprados y el PC se inicia sin errores.

¿Alguna idea? Gracias.
 
Última edición:

Segador

Honorable
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Buenos días:

Hace unos años monté una máquina gracias a la ayuda de este foro (ver configuración completa).

Por requerimientos de procesamiento de imágenes para la producción de ortofotografías aéreas, he aumentado de 32GB (16x2) de RAM a 64GB (16x4), todos de la misma marca y modelo Corsair VENGEANCE RGB PRO 16GB, DDR4 3200MHz C16.

Desde que he hecho ese cambio, el PC no inicia. Tengo que apretar el botón reset de reinicio para que se inicie correctamente y cargue W11. Una vez hecho esto, el PC funciona sin problemas con sus 64GB de RAM. La placa (ROG Strix X570-E Gaming) me indica que el error Q-code es el 22, que corresponde con un problema de la RAM (Q-LED detenido en amarrillo).

He probado a instalar sólo los dos módulos recién comprados y el PC se inicia sin errores.

¿Alguna idea? Gracias.
Hola!

Siendo todos de las mismas características y además de la misma marca, no debería dar problemas.

¿Has entrado en la BIOS para configurar tus nuevos módulos?.

Selecciona un perfil XMP 3200 para todos los módulos y grabas los cambios. Con esto debería bastar...

Ya nos contarás.
 


Nota: Ver precios en PC Componentes Click aquí
Nota 2: En comunidad la ayuda ha de ser reciproca, busca temas sin respuesta y participa

Segador

Honorable
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Ok.

Te aconsejo lo siguiente:
Bájate el CPU-Z, y una vez iniciada la aplicación, accede a la pestaña "SPD". Captura esa pantalla y la compartes por aquí, por favor.

Se trata de comprobar la tabla de valores/latencias de tus módulos DRAM, y ver si coinciden con los que tienes en la BIOS.

Saludos.
 

pindio

Miembro del Foro
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Ok.

Te aconsejo lo siguiente:
Bájate el CPU-Z, y una vez iniciada la aplicación, accede a la pestaña "SPD". Captura esa pantalla y la compartes por aquí, por favor.

Se trata de comprobar la tabla de valores/latencias de tus módulos DRAM, y ver si coinciden con los que tienes en la BIOS.

Saludos.
Ahí van:
2022-07-26.png
2022-07-26 (1).png
2022-07-26 (2).png
2022-07-26 (3).png
 

Segador

Honorable
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Pues ya tenemos donde está el problema. A pesar de ser los mismos módulos y frecuencia, tienen valores diferentes, además de tener chips de diferente marca (Micron & Hynix).

Tendrás que introducir los valores a mano, y olvidar el XMP auto.

Anota los valores:
CAS#, RAS# TO CAS#, RAS# PRECHARGE, tRAS, TRC, más altos: 16-20-20-38-58, que son los que aparecen en esta pantalla:

2022-07-26 (3).png

Mi bios es diferente a la tuya, por lo que no puedo guiarte concretamente hasta esa pantalla. Deberás ir probando. Si tienes algún problema, captura pantallas y las compartes por aquí. Intentaré decirte cual es.

Se trata de intentar que los 4 módulos funcionen con los valores más altos de latencia para crear estabilidad.

Ya contarás...

Saludos.
 

pindio

Miembro del Foro
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Pues ya tenemos donde está el problema. A pesar de ser los mismos módulos y frecuencia, tienen valores diferentes, además de tener chips de diferente marca (Micron & Hynix).

Tendrás que introducir los valores a mano, y olvidar el XMP auto.

Anota los valores:
CAS#, RAS# TO CAS#, RAS# PRECHARGE, tRAS, TRC, más altos: 16-20-20-38-58, que son los que aparecen en esta pantalla:

Ver el archivo adjunto 5009

Mi bios es diferente a la tuya, por lo que no puedo guiarte concretamente hasta esa pantalla. Deberás ir probando. Si tienes algún problema, captura pantallas y las compartes por aquí. Intentaré decirte cual es.

Se trata de intentar que los 4 módulos funcionen con los valores más altos de latencia para crear estabilidad.

Ya contarás...

Saludos.
Muchísimas gracias @Segador Mañana o el jueves (fiesta) lo pruebo.
 

Segador

Honorable
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Muchísimas gracias @Segador Mañana o el jueves (fiesta) lo pruebo.
No hay de qué.

Si modificando valores en la bios, se te colgase el PC en el inicio, siempre puedes hacer un reset para volver a los valores de fábrica (quitando la pila durante unos instantes).
Saludos.
 

pindio

Miembro del Foro
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Buenas tardes @Segador :

Tu ayuda me ha servido para resolver el problema.

Una vez que me orientaste hacía dónde y qué había que mirar, se me ocurrió, antes de poner en práctica tu consejo de introducir a mano los parámetros de los módulos de memoria en la BIOS, reordenar la colocación de los módulos de memoria RAM en las ranuras de la placa base atendiendo a los valores de sus parámetros. ¡¡¡Y se solucionó!!! Enciende sin problemas a la primera.

Muchísimas gracias a todos.

Así quedan:
2022-07-27.png
2022-07-27 (1).png
2022-07-27 (2).png
2022-07-27 (3).png
 

Segador

Honorable
Amigo Del Foro .:VIP:.
Compra/Venta Verificado
Genial que lo hayas podido solucionar. :)

Un saludo !!
 

Últimos mensajes

Arriba
Esta web usa cookies y participa en el Programa de Afiliados de Amazon EU, un programa de publicidad para afiliados diseñado para ofrecer a sitios web un modo de obtener comisiones por publicidad, publicitando e incluyendo enlaces a Amazon.es . En calidad de Afiliado de Amazon, obtengo ingresos por las compras adscritas que cumplen los requisitos aplicables